Namespaces

Variants
Actions
Personal tools

Dell Latitude D420

From UABgrid Documentation

Jump to: navigation, search

I recently purchased a Dell Latitude D420. It's a nice lightweight, compact laptop. Very protable. The install of openSUSE 10.2 was painless with the main extra step so far having been to install the Intel ipw3945 wireless driver to support the built-in wifi. I'll maintain other notes about my config here.

Contents

Monitor Config

The screen config works with the out of box openSUSE 10.2 install in 1280x800 mode. The biggest annoyance is this is a little off from the 16:9 aspect ratio of the screen. The SAX2 config through YaST offers a 1344x768 (or something like that) mode which would be perfect 16:9. Unfortunately selecting and saving this resolution mode doesn't get it to stick. It always reverts to 1280x800 mode.

The chipset for the Dell D420 is Intel 945GM. There is some confustion on whether the chipset is 945 or 950 chipset. http://www.intel.com/products/chipsets/945g/index.htm Intel docs for 945G Express Chipset] indicate that the GMA950 is the graphics core, though. In any case, the driver is maintained at Intel's open source driver site but that says the driver should be part of the X.org distribution and seems to be identified as the i810 driver. According to the SAX2 config, this is the one that is auto-detected. Multiple-resolutions do show up but the one I want doesn't want to stick.

There are instructions for Ubuntu on how to set this up using an imported RPM from openSUSE 10.1. The instructions are from Dec 2006 and may not be relevant anymore.

I haven't been able to figure out if there is a more specific driver package I need to install or if this is the "best" config possible.

Update - The 1344x768 config seems to stick in the xorg.conf file but I'm not sure if that's the one actually being used when running X. Cycling through the resolution modes with Ctrl+Alt+Fn+Numeric- only has about 3 modes rather than the 6 or so listed in the xorg.conf

Touch-pad Mouse Config

One guy has a light config about configing Fedora 6. His sample Xorg config shows a setting of MaxTapMove and MaxTapTime for the touchpad mouse which might help with some over-sensitivity in the mouse scolling and tapping. Will need to look up these settings in more detail.

Buglets

Sound

The sound is buggy when returning from suspend-to-disk. Usually, all that is required to get the sound working again after booting from suspended mode is to adjust the volume with the desktop slider bar (KMix).

Wifi

The wifi generally works well. Sometimes there are problems negotiating WEP-based secure connections after a suspend. The problem shows up as KNetworkManager not interacting with KWallet correctly and prompting the user for the passphrase. Most of the time, this can be corrected by stopping knetworkmanager, restarting the network service, and restaring knetworkmanager. Other times it requires rebooting.

The situation of the wifi not coming up at all after boot (suspended or not) has happened once. The green wifi light doesn't blink and ifconfig and iwconfig give no indication there is even a wifi device. (It doesn't even show up in the boot logs). It does show up in YAST but trying to reconfigure it there didn't trigger a wakup. Rebooting didn't help either. The only way I got it working was to go into the BIOS and "look" at the wireless settings. Didn't change anything. Exited BIOS and rebooted and this time the wifi link came back up.